We noticed a stream is unable to start if a write token is expired (past its ttl)
In a nutshell what happens in this case is the manager wont let the user deactivate the stream because the token is expired however when you try to start the stream the manager will try to reuse the expired write token because is present in the metadata.
I got around the issue by manual removing the write token in the meta and was able to start a stream.
We noticed a stream is unable to start if a write token is expired (past its ttl)
In a nutshell what happens in this case is the manager wont let the user deactivate the stream because the token is expired however when you try to start the stream the manager will try to reuse the expired write token because is present in the metadata.
I got around the issue by manual removing the write token in the meta and was able to start a stream.