You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
{{ message }}
Repository navigation
ARM OpenSSL version causing Tenable "OpenSSL 3.5.0 < 3.5.7 Multiple Vulnerabilities" #10415
Thanks for reaching out @alex-rowe. The AWS CLI doesn't call the PKCS#7, CMS, PKCS#12, CMP, QUIC, or AES-OCB/SIV code paths these CVEs require, so it isn't affected. We'll keep this open until the bundled OpenSSL is updated to 3.5.7 for the Linux installers so scanners stop flagging it, and update here when it ships.
This issue is now closed. Comments on closed issues are hard for our team to see.
If you need more assistance, please open a new issue that references this one.
Activity
adev-code commentedon Jun 26, 2026
Thanks for reaching out @alex-rowe. The AWS CLI doesn't call the PKCS#7, CMS, PKCS#12, CMP, QUIC, or AES-OCB/SIV code paths these CVEs require, so it isn't affected. We'll keep this open until the bundled OpenSSL is updated to 3.5.7 for the Linux installers so scanners stop flagging it, and update here when it ships.
ashovlin commentedon Jul 2, 2026
We upgraded OpenSSL to 3.5.7 in the Linux installers in 2.35.14 released today. Let us know if you're still seeing scanner results after upgrading.
github-actions commentedon Jul 2, 2026
This issue is now closed. Comments on closed issues are hard for our team to see.
If you need more assistance, please open a new issue that references this one.