-
Notifications
You must be signed in to change notification settings - Fork 2
/
Copy path18.1 Reverse Array.java
95 lines (61 loc) · 1.56 KB
/
18.1 Reverse Array.java
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
/*
write a program that creates integer array of n elements, accepts the values of arrays and print the array in reverse :
Input Format
Accepts n values from the user.
Constraints
All number should be integer values (Positive, negative and zero)
Output Format
It should first display original array and after reversing the array it should display the reverse array.
Sample Input 0
8 7 4 3
Sample Output 0
3 4 7 8
*/
//Note : sice there are some test case giving invalid input thats why we used Execptional Handdling
import java.io.*;
import java.util.*;
public class Solution {
public static void main(String[] args) {
/* Enter your code here. Read input from STDIN. Print output to STDOUT. Your class should be named Solution. */
Scanner sc = new Scanner(System.in);
String []arr = new String [50];
Arrays.fill(arr,"#");
int n=50;
for(int i=0;i<50;i++)
{
try
{
arr[i] = sc.next();
}
catch(Exception e)
{
n = i;
break;
}
}
for(int i=n-1;i>=0;i--)
System.out.print(arr[i]+" ");
}
}
// other solutions
import java.io.*;
import java.util.*;
public class Solution {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int n = sc.nextInt();
if(n<=0){
return;
}
int[] ar = new int[n];
int i = 0;
while(sc.hasNextInt()){
ar[i] = sc.nextInt();
i++;
}
int m = i;
for(int j=m-1;j>=0;j--){
System.out.print(ar[j]+" ");
}
}
}